PHP, which is a recursive backronym for PHP: Hypertext Preprocessor, is among the most commonly used server-side coding languages out there. Any site or application built using PHP will run on a given web server on the condition that a PHP module is enabled, which renders the language absolutely universal and it is hardly a surprise that there are actually a few million servers that support it and 100s of millions of PHP-driven sites hosted on them. PHP is preferred over HTML because of the fact that it permits you to build a dynamic site with heaps of features. A PHP-based community web portal, for instance, will show different content to each visitor regardless of the fact that the page URL will remain the same. In comparison, HTML-based websites are static and the page content can be updated only manually. Like any other piece of software, PHP has different versions and the version that was used whilst building a certain website must be activated on the web server in order for the site to run correctly.

PHP 4, PHP 5 and PHP 7 Support in Website Hosting

With our website hosting, you will be able to select the version of PHP that will be active for your shared account, as multiple versions are supported on our servers. With only one mouse click, you’ll be able to switch between PHP 4, 5, 7 and every time a new version is released in the future, we’ll include it in the Hepsia hosting Control Panel without removing the earlier versions. In this way, you will be able to host all the sites that you’ve set up over the years. In stark contrast with lots of other hosting vendors, we will not compel you to update such sites, as a script may be out of date, but this does not automatically mean that it is insecure since you may have modified its code to plug safety holes. For the sake of your convenience, you’ll even be able to select a different PHP version for each individual website that you host in your shared web hosting account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Servers

If you have a website created in an older PHP version and you’ve put time and efforts into developing it, repairing security breaches and entering web content, you will need a hosting service that can support it, as the majority of web hosting vendors these days offer support only for the most recently unveiled version of PHP and drop the previous ones. We, on the other hand, have decided to allow you to pick the exact version that your very own sites need. Our semi-dedicated hosting plans support PHP 4, PHP 5 and PHP 7, so you will be able to use both newer and older scripts without losing any manual modifications or misspending time and energy struggling to make your sites compatible with the web hosting environment. You can change the version from the Hepsia hosting Control Panel and such an update will affect the entire account, but you will also have the ability to set a different PHP version for each site that you host in your account using an .htaccess configuration file.